How to Update a GPL Theme Plugin

All GPL themes and plugins are easily updated as follows:

IMPORTANT: We recommend installing the plugin “Easy Theme and Plugin Upgrades” before use GPL items. You can download it for free by CLICKING HERE . You can also search it from your control panel within the WordPress free plugin repository as a new plugin to add.

 

To use it, first install and activate the Plugin. Once activated, you can install and update any theme/plugin by simply uploading a .zip file.

By installing and activate this Plugin before installing any theme or GPL Plugin you can avoid update conflicts if you already have a previous version of the product to update.

HOW TO UPDATE  A PLUGIN:

  1. Login to gpldownloads.club and Download the latest .zip file for the plugin from MY ACCOUNT>>DOWNLOADS. You will notice that it is the new version because its number will have changed.
  2. Login to your WordPress website.
  3. Go to “Plugins”>”Add New”. (Even though you are updating)
  4. Click on  “Upload Plugin” button at the top of the page.
  5. Select the .zip file with the updated version of the plugin.
  6. Click the “Install Now” button.
  7. Once installed, click “Activate”.

HOW TO UPDATE A THEME:

  1. Login to gplplugins.club and Download the latest .zip file of the theme from MY ACCOUNT>>DOWNLOADS. You will notice that it is the new version because its number will have changed.
  2. Log in to your WordPress website.
  3. Go to “Appearance”>”Themes”.
  4. Click the “Add New” button at the top of the page. (Even if you are updating)
  5. Click on the “Upload topic” button at the top of the page.
  6. Select the .zip file with the updated version of the theme.
  7. Click the “Install Now” button.
  8. Click “Activate”.

DO YOU HAVE AN ERROR WHEN UPDATING?

 

1. It is very important that you do not forget that some products (for example those of Themeforest and Codecanyon) in many occasions come in a double compression, that is to say, a zip file inside another zip.

Check your product when downloading BEFORE INSTALLING to see if this is the case because if it is, the main zip you downloaded will not be the installable one, which will lead you to installation errors like “The package could not be installed. The theme is missing the style.css stylesheet.” for example.

If you upload the main zip and receive an error, it is most likely because the main zip is not the installable one. Unzip the main zip and you will find the installable zip inside.

2. Remember that the Plugins, Extensions and Addons are always uploaded in the Plugins area. And the themes always in the Appearance area.

3. You MUST make sure that your WordPress installation meets the minimum requirements suggested in our Q&A section, which are as follows:

Before purchasing a subscription, pass or individual product on the website, make sure your hosting meets the following minimum requirements for WordPress:

Apache or NGINX based web server with 128MB of RAM
PHP version 5.6 or 7.0
MySQL version 5.6+ or MariaDB version 10.0+
Apache Module mod_rewrite

4. To avoid errors during product installation, make sure you are using the correct PHP settings on your web server:

max_execution_time = 600;
max_input_vars = 5000;
memory_limit = 256M;
post_max_size = 128M;
upload_max_filesize = 128M;

5. For themes with a weight of more than 200 megabytes (which include the different templates) it is necessary that you make your upload through FTP.